Exception: Scenic::Adapters::Postgres::ConcurrentRefreshesNotSupportedError

Inherits:
StandardError
  • Object
show all
Defined in:
lib/scenic/adapters/postgres/errors.rb

Overview

Raised when attempting a concurrent materialized view refresh on a database version that does not support that.

Concurrent materialized view refreshes are supported on Postgres 9.4 or newer.

Instance Method Summary collapse

Constructor Details

#initializeConcurrentRefreshesNotSupportedError

Returns a new instance of ConcurrentRefreshesNotSupportedError



20
21
22
# File 'lib/scenic/adapters/postgres/errors.rb', line 20

def initialize
  super("Concurrent materialized view refreshes require Postgres 9.4 or newer")
end