Exception: Scenic::Adapters::Postgres::MaterializedViewsNotSupportedError

Inherits:
StandardError
  • Object
show all
Defined in:
lib/scenic/adapters/postgres/errors.rb

Overview

Raised when a materialized view operation is attempted on a database version that does not support materialized views.

Materialized views are supported on Postgres 9.3 or newer.

Instance Method Summary collapse

Constructor Details

#initializeMaterializedViewsNotSupportedError

Returns a new instance of MaterializedViewsNotSupportedError



9
10
11
# File 'lib/scenic/adapters/postgres/errors.rb', line 9

def initialize
  super("Materialized views require Postgres 9.3 or newer")
end